[POJ 1915] Knight Moves【双向BFS】

  • 2017-12-31
  • 0
  • 0

Problem:

Time Limit: 1000MS Memory Limit: 30000K

Description

Background
Mr Somurolov, fabulous chess-gamer indeed, asserts that no one else but him can move knights from one position to another so fast. Can you beat him?
The Problem
Your task is to write a program to calculate the minimum number of moves needed for a knight to reach one point from another, so that you have the chance to be faster than Somurolov.
For people not familiar with chess, the possible knight moves are shown in Figure 1.

Input

The input begins with the number n of scenarios on a single line by itself.
Next follow n scenarios. Each scenario consists of three lines containing integer numbers. The first line specifies the length l of a side of the chess board (4 <= l <= 300). The entire board has size l * l. The second and third line contain pair of integers {0, ..., l-1}*{0, ..., l-1} specifying the starting and ending position of the knight on the board. The integers are separated by a single blank. You can assume that the positions are valid positions on the chess board of that scenario.

Output

For each scenario of the input you have to calculate the minimal amount of knight moves which are necessary to move from the starting point to the ending point. If starting point and ending point are equal,distance is zero. The distance must be written on a single line.

Sample Input

3
8
0 0
7 0
100
0 0
30 50
10
1 1
1 1

Sample Output

5
28
0

Source

TUD Programming Contest 2001, Darmstadt, Germany

Solution:

BFS 的模板题,可以使用双向 BFS 求解,效率比直接 BFS 求解有显著提高。

Code: O(TL2) [1428K, 47MS]

#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<cmath>
#include<iostream>
#include<algorithm>
#define MAXL 302
using namespace std;
const int dx[8] = {1, 2, 2, 1,-1,-2,-2,-1};
const int dy[8] = {2, 1,-1,-2,-2,-1, 1, 2};

int n, l;

struct Position{
	int x, y;
	
	Position() {}
	Position(int x, int y): x(x), y(y) {}
	
	inline bool isLegal() {return x >= 0 && x < l && y >= 0 && y < l;}
} s, t;

struct Queue{
	#define MAXNODE (MAXL * MAXL)
	#define inc(x) (x) = (x + 1 >= MAXNODE ? x + 1 - MAXNODE : x + 1)
	
	Position node[MAXNODE];
	int fr, re;
	
	inline void clear() {fr = re = 0;}
	
	inline bool empty() {return fr == re;}
	
	inline void push(Position x) {node[re] = x, inc(re);}
	
	inline void pop() {if(!empty()) inc(fr);}
	
	inline Position front() {return node[fr];}
} q;

int vis[MAXL][MAXL], dis[MAXL][MAXL];

inline int bidirectional_BFS(){
	if(s.x == t.x && s.y == t.y) return 0;  // s, t are equal
	memset(vis, 0, sizeof(vis)), q.clear();
	q.push(s), vis[s.x][s.y] = 1, dis[s.x][s.y] = 0;  // Reach from origin
	q.push(t), vis[t.x][t.y] = 2, dis[t.x][t.y] = 0;  // Reach from destination
	while(!q.empty()){
		Position u = q.front();
		q.pop();
		for(register int i = 0; i < 8; i++){
			Position v(u.x + dx[i], u.y + dy[i]);
			if(!v.isLegal()) continue;
			if(!vis[v.x][v.y]){
				q.push(v);
				vis[v.x][v.y] = vis[u.x][u.y];
				dis[v.x][v.y] = dis[u.x][u.y] + 1;
			}
			if(vis[v.x][v.y] != vis[u.x][u.y])  // Two paths meet
				return dis[u.x][u.y] + dis[v.x][v.y] + 1;
		}
	}
	return -1;
}

int main(){
	scanf("%d", &n);
	while(n--){
		scanf("%d%d%d%d%d", &l, &s.x, &s.y, &t.x, &t.y);
		int minStep = bidirectional_BFS();
		printf("%d\n", minStep);
	}
	return 0;
}

评论

还没有任何评论,你来说两句吧



新博客地址:
darkleafin.cf
(该域名已过期且被抢注。。)
darkleafin.github.io


常年不在线的QQ:
49750

不定期更新的GitHub:
https://github.com/Darkleafin


OPEN AT 2017.12.10

如遇到代码不能正常显示的情况,请刷新页面。
Please refresh the page if the code cannot be displayed normally.


发现一个优美的网站:
https://visualgo.net/en
















- Theme by Qzhai